Restaurar el Grub en computadoras MX


IMG_00000319_hdr

 

Uno de los problemas que afrontan los poseedores de una computadoras MX es la falla del GRUB, el cual es el sistema que hace que cargue el sistema operativo, los que experimentan este problema encuentran que su equipo manda errores al incoar y se queda en una pantalla negra con letras blancas, para solucionar esto, debemos realizar el procedimiento que el Ing, Juarez nos aporta en un comentario y que recogimos para que fuera de mas fácil acceso.

Copiamos el procedimiento tal cual nos lo dejo el Ing. Juarez en un comentario para evitar alterarlo accidentalmente, y es el siguiente.

 

amigo, en mi experiencia actual. fue problemas de GRUB
lo solucione de esta manera
Busque una distribución linux forense pero puedes utilizar cualquier otra
ya sea ubuntu
inicie desde un live cd ubuntu en mi caso use (backbox linux)
inicio un terminal
y escribo los siguientes comando:
sudo su
…. para trabajar en modo super usuario o Root

mount /dev/sda2 /mnt
mount –bind /dev /mnt/dev
mount –bind /dev/pts /mnt/dev/pts
mount –bind /proc /mnt/proc
mount –bind /sys /mnt/sys

chroot /mnt
si al ejecutar el comando chroot te sale el siguiente error:

chroot: cannot run command `/bin/bash’: Exec format error

ignoralo y ejecuta el siguiente comando

grub-install –root-directory=/mnt/ /dev/sda

te debe arroja el siguiente mensaje
Installation finished. No error reported.

reinicia con:

reboot

y ya debe iniciar de manera normal
espero sea la solución para algunos problemas de dicho proyecto suerte..
he escuchado que la compañía que elaboro dicho proyecto ha tenido muchas quejas..
escuche no se si sea cierto. pero no lo podrán negar.. que si tiene muchos errores.

correo de contacto es: cieincorp@gmail.compara cualquier duda.. saludos

estoy en la solucion de ,ICEauthority en la cuenta alumno. espero alguien haya tenido solución por que intenten con la restauración y sigue dando lo mismo

 

Para terminar, agracedemos al Ing, Juarez por compartir esta solución y permitirnos ponerla en forma de post

 

Anuncios

Acerca de sistemasumma

Blog dedicado a la tecnología y a todos los estudiantes de sistemas, informatica, computación y afines
Esta entrada fue publicada en computadoras mx, General y etiquetada , , , . Guarda el enlace permanente.

107 respuestas a Restaurar el Grub en computadoras MX

  1. luis dijo:

    No podra poner un video encerio no puedo mi facebook es luis rangel herrera dinganpor ay

    Me gusta

  2. angel gustavo dijo:

    Chido si la compuse

    Me gusta

  3. Cesa Antonio Varela lopez dijo:

    Pongo la memoria con él programa de boot repair.. Y no funciono dice que no puede arrancar

    Me gusta

  4. cotorrox11 dijo:

    no se se ese prodedimiento

    Me gusta

  5. cotorrox11 dijo:

    porfa que alguien me ayude que mi compu dice image loadig failure reload image

    Me gusta

  6. Luis Espinoza dijo:

    Hola, podrian pasarme la linea de comando para arrancar desde la particion que tiene clonezilla? hice unos movimientos y solamente tengo el grub para escribir bash, lo que quiero es que me pasen toda la linea que aparece al seleccionar del grub normal “Restaurar sistema”, presionar la tecla TAB y supongo que debe de aparecer la linea que deseo probar en una de estas laptop. Gracias de antemano y saludos!

    Me gusta

  7. shawn hammond dijo:

    mi compu no funciona y dice

    error: symbol not found: ‘grub_divmod64_full’
    Entering rescue mode

    Me gusta

  8. luis dijo:

    Que tal que hago con:
    image loading failure . reload image!
    Tengo una usb con obuntu
    ¿La puedo recuperar?

    Me gusta

  9. Hola, tengo un problema, la computadroa enciende pero aparece

    error: symbol not found: ‘grub_divmod64_full’
    Entering rescue mode

    Me gusta

  10. Gustavo Corrales dijo:

    Amigo sistemasumma porfa podrias hacer un video donde expliques como donde y cuanfo insertar los comandos de la informacion de arriba…..xfaa asme ese favor porque ya no se que hacer

    Me gusta

  11. MARIA NATIVIADAD dijo:

    HOLA UNA DUDA ESTO SIRVE TAMBIEN SI ME APARECE: IMAGE LOADING FAILURE.RELOAD

    Me gusta

  12. Joel Caldera dijo:

    Buenas tardes No se si alguien mas tuvo problemas para entrar al modo “Super Usuario”o Root??? en la compudaroa MX nadie????
    De antemano Gracias…..

    Me gusta

  13. Rodrigo Campa dijo:

    Esto lo tengo que escribir donde dice grub rescue》

    Me gusta

  14. merardo dijo:

    si me aparese este error, puedo acer que no este con solo istalar el windows 7?

    Me gusta

  15. IVAN dijo:

    tengo un problemilla el mismo en 3 laps mx
    al prenderla da el texto
    Image loading failure. reload image¡

    usando gnu grub version 1.98
    selecciono
    –detect any os. y resulta error: no os found
    –detect any grub2 configuration file (grub.cfg) y resulta— could not find any grub.cfg files
    –detect loop bootable isos y resulta error: no iso files were found in (x ruta)
    –detect any grub2 installation (even if mbr is overwritten) y resulta could not find any core. img files

    y usando el boot repair ps no pasa nada

    se me hace raro que antes con estos 2 procedimientos si se reparaba ese problema
    y derrepente me llegen 3 con el mismo problema

    me gustaria saver como resolverlo y si se trata de lagun error por alguna nueva actualizacion o que
    gracias

    Me gusta

  16. jose carlos dijo:

    Hola, ya hice este procedimiento y funciono pero al encenderla me da las siguientes opciones:

    * Linux
    * Restaurar sistema

    y en cualquiera de las dos me pide un usuario y contraseña

    Me gusta

  17. Anónimo dijo:

    SALUDOS ING JUAREZ.- CUAL ES TU CORREO

    Me gusta

  18. fernando dijo:

    Aaaa otra cosa no marca ningun error todo corre bien pro ai se qeda atorado en los 5 puntitos.. Xfa ayudenmen como solucionar pso a pso xfa.

    Me gusta

  19. fernando dijo:

    Los que pasa mi hermano tnia la lap pro el dce le sako solo la pila y ps despues al prende ya no psa d los 5 puntitos blancos dond sta la señora cn la bndera ya restaure el sistema pnsando qe eso pro ps sige lo mismo ai se qeda prodian ayudarme a como solucionarlo.. Ya lei qe pero no se cmo acerlo qe tengo qe hacer podrian explikarmelo bien xfa soy de comalcalco tab. Espero respuesta.. Antes funcionaba bien no se qe ocurrio..

    Me gusta

  20. fkolansinsky dijo:

    hola quisiera que ma ayudaran tengo un problema con la mini laptop de mi hijo, me sale el error donde dice: hd0,msdos2 reader error y no se que hacer……al parecer me dijieron que el disco duro tiene algunos errores quisiera saber si es cierto o es otra cosa…o si con este post se soluciona no lo he hecho pero quiero asegrarme..

    Me gusta

    • linuxmanr4 dijo:

      Por el hd0 parece que es un problema con el grub, puedes intentar arreglarlo con boot-repair, en este mismo sitio hay un video que dice como hacerlo.

      ¿Una pregunta? intentaste instalarle windows? actualizaste el sistema de linux? o sólo apareció el error?

      Me gusta

  21. emargally dijo:

    Tengo una laptop mx , bueno es que se actualizo y luego se reinicio , cuando encendio salio :
    GRUB loading.
    Welcome to GRUB !
    error:symbol not found: ‘grub_divmod64_full’ .
    Entering rescue mode…
    grub rescue>
    Cual es la solucion o hay una solucion sin usar disco ?

    Me gusta

  22. Anónimo dijo:

    amigos; mi maquina se queda cargando y no inicia, ya lo restaure y sigue en lo mismo

    Me gusta

  23. Luis dijo:

    Me sale este problema /run/rootdev: UNEXPECTED INCONSISTENCY: RUN fsck MANUALLY saben como solucionarlo?

    Me gusta

  24. noemi dijo:

    buenas me urge me responda como instalo nuevamente el sistema operativo en la lap ya que le borraron el sistema que trajo como le hago para instalarlo de nuevo y dejarla como la entregaron mi correo es lirio_azul7@hotmail.com agradecería me dijeran

    Me gusta

  25. Jorge dijo:

    tratando de. arreglar el grub me sale el error de no boot signature in partition alguien sabe como arreglarlo?

    Me gusta

  26. mario dijo:

    alguien que pueda pasarme la enciclopedia mx por favor gracias

    Me gusta

  27. linuxmanr4 dijo:

    Me encontré este excelente artículo sobre como recuperar GRUB en cualquier distro basada en Debian, esta muy bien explicado cada punto…

    http://geekland.hol.es/recuperar-el-grub/

    Pero insisto deberían de probar boot repair que hace el proceso mucho más sencillo.

    Nota aparte merecen mención las razones por las que se corrompe grub:

    Si tienes un sistema GNU Linux instalado y posteriormente instalas Windows es posible que Windows sobrescriba el sector de arranque MBR. Como consecuencia nuestro grub desaparecerá y no podremos seleccionar con el sistema operativo que queremos arrancar.

    Cuando estáis modificando y jugando con las particiones de vuestro ordenador también es posible que rompáis el gestor de arranque. De hecho este ha sido mi caso. Al darle más espacio a una de las particiones he roto el gestor de arranque.

    Me gusta

  28. jacotasa dijo:

    Seguí este tutorial, pero para cualquier opcion del GRUB que se muestra me pide “introduzca nombre de usuario” “introduzca contraseña” tarda un buen rato y vuelve a las mismas 5 opciones de arranque. ¿que podrá ser?

    Me gusta

    • jacotasa dijo:

      Abonando a mi mensaje, despues de que la Lap solo encendía en una línea de comandos “grub rescue>”, logré con este procedimiento entrar al GNU GRUB versión 2.00-19ubuntu2, pero de ahí no pasa… les dejos dos imágenes de lo que pasa al agarrar una opción (cualquiera de las 5):

      Espero su ayuda o de plano para enviarla a soporte, aunque es una buena oportunidad de aprender mas de Linux.

      Me gusta

      • sistemasumma dijo:

        dado que te aparece el menú del grub intenta usar la opción de restaurar

        Me gusta

      • jacotasa dijo:

        Gracias, pero también esa opción me manda a lo de “introduzca nombre de usuario” “introduzca contraseña” y regresa al GRUB… pude ver (por cuestión de un segundo) que manda un mensaje al escribir cualquier contraseña (la de familia, la de soporte o la del alumno) que dice “acceso denegado” y de inmediato vuelve al menú GRUB.

        Me gusta

      • linuxmanr4 dijo:

        Que interesante, porque al parecer pusieron una contraseña al grub, pero no es algo sencillo de hacer 🙂

        Nadie ha intentado reparar el grub con boot-repair ? http://linuxmanr4.com/2014/02/13/arreglando-grub-con-boot-repair/

        Me gusta

        • jacotasa dijo:

          Bueno, la solución fue hablar a Soporte Técnico (Al 01 800 que viene en la parte tracera de la Computadora MX), intentaron solucionarlo y al final me dieron un folio para llevarlo al centro autorizado acá en Hermosillo.

          Me comentaron que a esa computadora le habían instalado un GRUB de Debian que no correspondía al que traía originalmente la computadora por lo que se pedía una contraseña para aceptar los cambios y que por tal motivo no entraba en garantía.

          Le comenté que si había sido así, pues al querer instalar el programa Kanagram que viene en el repositorio fue cuando se presentó la falla con el GRUB y que si no entraba por garantía que mejor me la regresara para entregársela a la Escuela pues yo no iba a pagar por algo que, atendiendo el espíritu del programa de entrega de computadoras, que los chamacos en su afán de aprender le muevan a todo lo movible en esa computadora.

          Entró la persona que me atendió con el encargado y comentó que si la iban a meter por garantía.

          Cuando me entregaron la computadora me la entregaron como venía la primera vez, salvo que al entrar me salió un mensaje de que la contraseña de inicio no coincidía con la contraseña del repositorio de claves, pero fue un OK y ya no ha vuelto a salir nada.

          Eso fue lo que pasó en mi caso.

          Me gusta

        • Rodrigo Campa dijo:

          Mmm escribi eso y me salio Unknown command

          Me gusta

        • linuxmanr4 dijo:

          Lo que pasa Rodrigo es que ni siquiera te tomaste la molestia del leer el artículo que te recomendaron 🙂

          Me gusta

  29. Jorge dijo:

    escribi todos los comandos desde una terminal en ElementaryOS y al reiniciar me aparecido el menu de GRUB pero no me da opciones para accesar, es decir una tipo terminal de GRUB esperando que teclee algo.

    Me gusta

  30. Jorge dijo:

    hago todo el proceso pero cuando ejecuto la ultima línea me dice grub-install: command not found

    Me gusta

  31. julio jimeez dijo:

    que hacer cuando la pantalla se queda como cargando, tengo la pantalla de la mujer patria y con los puntos como si estuviera cargando, no sale ningun error ni nada solo se queda ahi, gracias

    Me gusta

    • linuxmanr4 dijo:

      Pues estaría adivinando, es en estos momentos cuando desearía tener a la mano uno de estos equipos para poder revisarlo a conciencia.

      ¿Hay actividad en el disco duro? … ¿Invernaste la maquina o la suspendiste?, ¿Has intentado presionar el botón de encendido por unos 5 o 6 segundos para que se apague y volverla a prender?

      Me gusta

  32. ing. Juarez dijo:

    amigos, ya restaure una MX espero compartirla, me dejo un buen sabor de boca, sistemasuma envíenme su correo… para que publiquen

    Me gusta

  33. ing. Juarez dijo:

    Hola amigos ya he solucionado otros de los problemas de estas laptop, espero enviarla a los administradores para que los publiquen, el sistema en general se encuentra en la misma lap escondida en una partición, dentro del mismo disco.
    saludos.. pronto tendrán el post. saludos

    Me gusta

  34. IVAN dijo:

    saludos
    gracias por estos post de estos equipos
    mi duda es
    una lap mx al prenderla sale la imagen inicial donde te da la opcion del boot bios y skip
    despues pantalla negra con el sig texto

    grub loading.
    welcome grub¡
    error symbol not found: grub_divmod64_full
    entering rescue mode…
    grub rescue>

    este mismo equipo si he podido entrar a las seciones con un disco de ubunto ¬¬creo no recuerdo
    y si le doy en la opcion suspender y la prendo de nuevo sigue siendo funcional
    pero al apagarse totalmente regresa a el anuncion anterior
    en que me pueden ayudar gracias

    Me gusta

    • linuxmanr4 dijo:

      Intentaste instalar otro sistema operativo?, ocurrió después de una actualización? …

      Muchas veces arreglo estos problemas reinstalando GRUB, pero puede ser algo complicado.

      Otra opción es intentar arreglarlo con boot-repair ( http://linuxmanr4.com/2014/02/13/arreglando-grub-con-boot-repair/ ) pero no estoy seguro si funcionará bien con estos equipos.

      Me gusta

      • IVAN dijo:

        no no se ha tratado de instalar ningun sistema operativo, tratare con el boot repair,
        otra cosa me llego una de la smismas que la trararon de apagar como si fuera de windows cntr+alt+f4 pasa que siguiente a eso salieron textos como si se estubieran checando los sectores del disco duro, saves algo de eso ?
        gracias

        Me gusta

        • linuxmanr4 dijo:

          Bueno en windows no se que pasa cuando presionas Ctrl + Alt+ F4 , pero en linux te debe de mostrar una pantalla tipo TTY (en este caso la 4) un mensaje de login en donde puedes teclear tu nombre de usuario y contraseña. Esto es porque linux es multiusuario y varios usuarios pueden usar el equipo al mismo tiempo.

          La combinación de de teclas funciona desde Ctrl + Alt + F1 a la F6 … F7 es tu interfaz gráfica.

          Con respecto a los mensajes que te aparecen, pues estaría adivinando… 🙂 a menos que los copies para ver los mensajes.

          Me gusta

      • sistemasumma dijo:

        oye aprovechando que aun nos acompañas en los comentarios, tengo una duda, dado que el sistema de restauración que traen las lao usa clonezilla, crees que sea factible montar la partición de rescate y copiar el archivo de imagen que trae por defecto el equipo y mucho mas importante usarlo para restaurar otros equipos, te pregunto porque siendo honestos hace algunos años que no uso linux y la verdad estoy algo obsoleto en ello, a la ves queremos agradecerte por ayudarnos en los comentarios del blog.

        Me gusta

        • linuxmanr4 dijo:

          A mi me gustaría más clonar el disco duro completo, de esa manera conservas la estructura de las particiones.

          Restaurar el disco duro completo de clonezilla al equipo y si algo sale mal intentar con la recuperación que debería de funcionar. 🙂

          Lo que no estoy seguro es como funcionan las licencias.

          Me gusta

      • johan dijo:

        Disculpa a mi me paso lo mismo despues de actualizar se renicio y cuando lo encendi me salio error: symbol not foun : ‘grub_divmod64_full’
        Entering rescue mode…
        grub rescue>
        Que es lo q puedo hacer ?

        Me gusta

        • sistemasumma dijo:

          en el renglón donde dice grub rescue>, gasa escribir

          set prefix=(sda,4)/boot/grub

          después

          set root=(sda,4)

          y terminas con

          insmod normal

          después de eso el equipo se debe reiniciar y funcionar, de todas formas avisamos si te sirvió

          Me gusta

    • sistemasumma dijo:

      desde el disco de ubuntu ejecuta el proceso que se describe en este post y con eso deberá quedar solucionado

      Me gusta

    • ing. Juarez dijo:

      ya he instalado ubuntu. y la plataforma MX me salio de 9 por que me falto los iconos. y algunas librerías pero saca de apuros.

      Me gusta

  35. esteban dijo:

    buen día ya lo restaure, pero se queda en la pantalla de inicio con una barra de progreso y no avanza… alguna sugerencia?

    Me gusta

  36. Pingback: Arreglando GRUB con Boot-Repair

  37. linuxmanr4 dijo:

    En todos los años que tengo trabajando con linux jamás he tenido problemas con grub. A menos claro que sea por un daño físico del disco duro. Casi puedo asegurar que los problemas vienen porque intentaron instalar windows y este destruye GRUB.

    No entiendo porque el afán de querer instalarle Windows a estos equipos.

    Me gusta

    • sistemasumma dijo:

      bueno yo si lo entiendo, porque la verdad la versión de Debian que le pusieron no tiene buen rendimiento, es mas, al querer insertar imágenes en algún documento hemos visto que se alenta demasiado, y atribuimos esto al sistema operativo porque tuvimos la oportunidad de ver un equipo de estos con Windows y la verdad el rendimiento y la calidad de la imagen en pantalla fue mucho mejor que con el Debian que traen instalado, y aclaro que no soy fan de Windows

      Me gusta

      • linuxmanr4 dijo:

        Es posible que el sistema no este optimizado, lamentablemente no tengo un equipo para evaluarlo.

        Veo por los screenshots que usan Gnome 3 como entorno de escritorio y puede ser muy pesado para un equipo de escasos recursos.

        Debian es estable, pero lamentablemente sus paquetes son viejos. En estos últimos 2 años me he decantado por Manjaro, siempre tiene un excelente rendimiento y una comunidad muy activa para ayudar cuando hay problemas.

        Lo tengo instalado en netbooks, notebooks y mi equipo de escritorio y todos con un rendimiento más que aceptable !!!

        El software libre es una excelente opción en las escuelas, gobierno e industria. Pero muchas personas están tan habituadas a Windows que se resisten al cambio.

        Si tuviera un equipo de estos en mis manos ya hubiera varios artículos sobre el tema 🙂

        Me gusta

    • ing. Juarez dijo:

      no as trabajado con linux, por que debian es un problema comun. bueno amigo.. expresa tus experiencias

      Me gusta

      • linuxmanr4 dijo:

        He trabajado con linux desde 1997 con varias distribuciones en mayor o menor grado tales como CentOS, Ubuntu, Mandriva, Manjaro, un poco con Fedora pero tienes razón, no he trabajado con Debian.

        Me gusta

        • sistemasumma dijo:

          yo era usuario de linux pero lo deje de usar hace algún tiempo, probé muchas distribuciones pero al igual que tu no use debían, aunque apoyo el uso de linux creo que debían no fue la mejor elección pues se encuentra muy poca documentación de esta distribución, digo, comparándola con el mundo de información que hay por ejemplo de Ubuntu, Mandriva, Red Hat y Fedora

          Me gusta

        • linuxmanr4 dijo:

          Hay mucha información sobre Debian, es una de las distribuciones más sólidas y es muy utilizada.

          Ubuntu esta basada en Debian.

          Me gusta

  38. Anonimo dijo:

    deberían de poner como descargarle juegos a la laptop .MX desde el centro de software.

    Me gusta

  39. Anónimo dijo:

    Hola, ya no puedo entrar en mi computadora me aparece Imagen loading failure. Reload image¡. Marque a soporte técnico y me siguieron que mi equipo esta dañado y me dieron un nuemero que marque y no me contestaron ando viendo vídeos por es de otras computadoras y no estoy segura.

    Me gusta

  40. Sanchez dijo:

    concuerdo con rodrigo de que ojala alguien pudiera publicar el SO o mas bien el gobierno deberia de publicarlo por que tiene muchos errores y fatales incluso he querido hacer lo mismo de poner dualboot pero por miedo a perder el sistema no lo ago mejor a que se este trababando en plena clase y los niños lo apaguen quitandole la bateria para reiniciarla de las 35 que entregaron en el salon de mi hermana 30 fallan y las otras 5 quedan en (no la llevan o estan en soporte tecnico)y como dicen los padres de familia ni eso tubieron la decensia de entregar bien un sistema si no todo mal como siempre en sus obras saludos desde villahermosa Tabasco a una peticion podrian ayudarnos a poner que esten los 2 sistemas windows y el dichoso sistema del gobierno gracias de antemano

    Me gusta

  41. rodrigo dijo:

    Disculpa podrias conseguir el SO con de la compus micomu.mx porfavor, borrer la particion de restauracion por instalar windows en dualboot y al actualizar el kernel de debian se quedo sin drivers de targeta grafica y ethernet y ahora no tengo como volver al kernel antiguo

    Me gusta

    • linuxmanr4 dijo:

      Al parecer es un kernel personalizado, se me ocurre que podrías clonar el disco de un equipo que funcione usando Clonezilla, restaurarlo en tu equipo y luego darle en Restaurar para que regrese a su configuración de fábrica.

      Me gusta

    • ing. Juarez dijo:

      oie, amigo no es necesario de conseguir, las laptop la tienen yo ya lo he echo, restauración de MX. y están en la particiones..
      escríbeme a mi correo..

      Me gusta

      • Miriam dijo:

        Hola Ing Juárez buenas tardes, soy Miriam de Sánchez Magallanes Cárdenas, Tabasco. He seguido sus comentarios y veo que ha hablado sobre gparted, honestamente yo no habia trabajado con linux hasta ahora que a mi hna le dieron la mx y ha tenido muchos problemas, quisiera me ayudara a solucionar el problema. Ya utilice boot repair y me dejo entrar pero se quedaba en los 5 puntos, hice lo mencionado en un comentario de esta misma pagina, al arrancar entre en recovey mode, segui las instrucciones y entro perfectamente a la maquina, pude usar todo muy bien, el problema es que al reiniciarla no vuelve a pasar de los 5puntos a menos que aplique el mismo procedimiento nuevamente

        Me gusta

¿Qué estas pensando?

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s